Global Prevent Auto-Submit

Global Prevent Auto-Submit

Postby dan76 » Mon Oct 15, 2012 6:18 am

There are many times when I visit a new website for the very first time, and Sticky Password tries sending one of my logins to that website even though I don't have an account for it. Yes, I do get a warning from Sticky Password that asks me if I want to proceed with submitting my info; however, I much rather prevent SP from trying to send ANY password unless I initiate the form being filled out myself.

Is there a way to set this? Maybe it's there but I'm just not finding it?
dan76
 
Posts: 4
Joined: Mon Oct 15, 2012 6:13 am

Re: Global Prevent Auto-Submit

Postby petr.pinkas » Mon Oct 15, 2012 8:57 am

Hello, can you let us know which sites are causing this? Maybe they have integrated some authorization method like Facebook connect etc.
Petr Pinkas
Sticky Password Team

ImageImageImageImageImage
petr.pinkas
Site Admin
 
Posts: 615
Joined: Fri Apr 24, 2009 10:22 am
Location: Czech Republic

Re: Global Prevent Auto-Submit

Postby dan76 » Mon Oct 15, 2012 11:41 pm

I don't have any examples offhand, because the problem happens randomly when I visit websites from a web search. Typically though, the websites causing problems are forums that are probably using a script that many other websites also use. I don't think they were using FB connect.

I'm also having problems when logged into my WordPress admin where SP keeps overwriting post fields with my login name. Because of all this, I much rather set SP so it NEVER fills out a form automatically unless I invoke it manually. Can this be done?
dan76
 
Posts: 4
Joined: Mon Oct 15, 2012 6:13 am

Re: Global Prevent Auto-Submit

Postby petr.pinkas » Tue Oct 16, 2012 8:40 am

Sure, in each particular account you can select the Options tab and then next to the Default Login field there is a checkbox "Automatic Log in" which you have to uncheck. This will figure this issue out. If not, let us know, we will have a look at that again, but we will need examples of those websites.
Petr Pinkas
Sticky Password Team

ImageImageImageImageImage
petr.pinkas
Site Admin
 
Posts: 615
Joined: Fri Apr 24, 2009 10:22 am
Location: Czech Republic

Re: Global Prevent Auto-Submit

Postby dan76 » Tue Oct 16, 2012 3:45 pm

petr.pinkas wrote:Sure, in each particular account you can select the Options tab and then next to the Default Login field there is a checkbox "Automatic Log in" which you have to uncheck. This will figure this issue out. If not, let us know, we will have a look at that again, but we will need examples of those websites.


Thank you, I had a hard time finding this option in this version.

Is there an easy way I can mass set all my existing logins to this setting? Also, can this be set as the default setting for any new passwords added?
dan76
 
Posts: 4
Joined: Mon Oct 15, 2012 6:13 am

Re: Global Prevent Auto-Submit

Postby dan76 » Tue Oct 16, 2012 3:54 pm

I might have figured out how to do the mass update, but please let me know if this will work...

I exported everything into an unencrypted xml file, and I can see that each record has: AutoSubmitAfterLoading="true" as an attribute. If I do a find/replace to delete all these occurrences and re-import, will this cause any problems?
dan76
 
Posts: 4
Joined: Mon Oct 15, 2012 6:13 am

Re: Global Prevent Auto-Submit

Postby petr.pinkas » Wed Oct 17, 2012 9:35 am

Yes, this is the solution which someone on this forum tried too and was successful. Unfortunately this can not be set as default - to not autologin automatically for new accounts.
Petr Pinkas
Sticky Password Team

ImageImageImageImageImage
petr.pinkas
Site Admin
 
Posts: 615
Joined: Fri Apr 24, 2009 10:22 am
Location: Czech Republic


Return to Sticky Password PRO 6

Who is online

Users browsing this forum: No registered users and 0 guests