Sticky Forum (and others) Autologin

Sticky Forum (and others) Autologin

Postby chaosxian » Sat May 11, 2013 4:59 pm

For some reason autologin is hit or miss for various sites, this forum being one of them. I've even used manual set up and again today autologin didn't work.

Is there a Firefox add-on that interferes with Sticky. For example, I use NoScript, but had turned the scripting function to "allow scripts globally" before bringing up this site.

This happens often on Google sites (for example, Latitude, Voice)

Any thoughts?
chaosxian
Experienced user
 
Posts: 105
Joined: Wed Apr 03, 2013 6:23 pm

Re: Sticky Forum (and others) Autologin

Postby Evzen » Sat May 11, 2013 8:16 pm

I had NEVER a problem with this forum... including times when I had NoScript installed... it has no influence on the functionality anyway...

Maybe you can tell us more details about WHAT is actually your problem with logging in this forum...

Maybe you are simply "expecting the impossible"?
For example, Sticky WON'T - because it CAN'T - automatically log you in when you click on a direct link to some particular thread/post... It's not possible because there is no login form displayed which Sticky would fill...
What I do in that case is open the Login link in a new tab (using middle mouse button) - Sticky logs me in automatically on this tab since there IS a login form - and then back on the original tab simply reload the page. And voila, I'm logged in!
It may sound a bit clumsy, but there is nothing Sticky can do about it - as long as there is no login form on the page, Sticky can't help in any way.

And that is the case of many other forums... is this perhaps what you are talking about?
Evzen
Experienced user
 
Posts: 163
Joined: Tue Jul 03, 2012 1:33 am

Re: Sticky Forum (and others) Autologin

Postby chaosxian » Sun May 12, 2013 3:32 am

I have the forum bookmarked to this url:
http://www.stickypassword.com/forum/

This most recent login completed my username and password, but I had to manually click the login button.

2013-05-11_21h27_56.png
2013-05-11_21h27_56.png (5.62 KiB) Viewed 2478 times
chaosxian
Experienced user
 
Posts: 105
Joined: Wed Apr 03, 2013 6:23 pm

Re: Sticky Forum (and others) Autologin

Postby Evzen » Sun May 12, 2013 10:42 am

Linking to the "Login" page (see the screenshot) works for me - Sticky submits this form automatically.

Oh, there is one more thing - Sticky won't autosubmit a form earlier than 5 minutes after last submit. This is to prevent endless cycles when a site redirects you back to login page after an unsuccessfull login.
In other words, you need to wait at least 5 minutes between tries when experimenting. Otherwise this feature kicks in and Sticky won't submit the form eventhough under a standard condition it would.
Attachments
SP_forum_login.png
SP_forum_login.png (5.06 KiB) Viewed 2472 times
Evzen
Experienced user
 
Posts: 163
Joined: Tue Jul 03, 2012 1:33 am

Re: Sticky Forum (and others) Autologin

Postby John Flyer » Sun May 12, 2013 4:26 pm

I have the same settings as you have, chaosxian, but my default browser is Chrome. I have never experienced any problems with the auto-login.

This topic was interesting, I was not aware of (or have not paid intention to) that it is possible to ask Sticky to use a specific browser for each of the accounts. I changed my SP forum account from “System default or current browser” to “Mozilla Firefox”. Clicked 'Launch' and was logged in with Firefox! This is great: I need Java RE for some sites, but due to all the security problems with Java, I have disabled Java in my default browser. When I need Java, I use Firefox. It is great to ask Sticky to take care of these choices!

I do not mean to offend you, chaosxian, but have you verified that the Firefox extension 'Sticky Password Autofill Engine 6.0.9.439' is properly enabled?
John Flyer
Experienced user
 
Posts: 125
Joined: Fri Jan 18, 2013 11:33 am

Re: Sticky Forum (and others) Autologin

Postby chaosxian » Mon May 13, 2013 4:11 am

I changed my bookmark link to the Login URL from Evzen's post. That seems to solve the problem here :D

It was also helpful to know about the 5 minute login period. Thanks!
chaosxian
Experienced user
 
Posts: 105
Joined: Wed Apr 03, 2013 6:23 pm

Re: Sticky Forum (and others) Autologin

Postby John Flyer » Mon May 13, 2013 9:22 am

chaosxian wrote:I changed my bookmark link to the Login URL from Evzen's post. That seems to solve the problem here :D

It was also helpful to know about the 5 minute login period. Thanks!

Do you mean, you changed the URL
from: http:// www.stickypassword.com/forum
to: http:// www.stickypassword.com/forum/ucp.php?mode=login
and then the auto-login executed as expected?
(Both URLs work flawlessly on my side.)

What about the Gmail accounts?
John Flyer
Experienced user
 
Posts: 125
Joined: Fri Jan 18, 2013 11:33 am

Re: Sticky Forum (and others) Autologin

Postby Evzen » Mon May 13, 2013 9:32 am

FWIW, the first link does NOT autosubmit the form in my Seamonkey too.
Evzen
Experienced user
 
Posts: 163
Joined: Tue Jul 03, 2012 1:33 am

Re: Sticky Forum (and others) Autologin

Postby John Flyer » Mon May 13, 2013 9:59 am

Thanks, Evzen. Then the problem is narrowed down to Seamonkey/Sticky. That is useful to other users reading this topic.

Evzen wrote:Sticky won't autosubmit a form earlier than 5 minutes after last submit
In other words, you need to wait at least 5 minutes between tries when experimenting.

Could you please elaborate this statement?

I tried to “test” this feature. I logged in and out. The login fields are immediately auto-filled. Have I misunderstood something?
John Flyer
Experienced user
 
Posts: 125
Joined: Fri Jan 18, 2013 11:33 am

Re: Sticky Forum (and others) Autologin

Postby Evzen » Mon May 13, 2013 10:33 am

Fields are filled, yes.
But the form is not submitted, even if you have auto-login turned on.
Evzen
Experienced user
 
Posts: 163
Joined: Tue Jul 03, 2012 1:33 am

Re: Sticky Forum (and others) Autologin

Postby chaosxian » Mon May 13, 2013 7:23 pm

John Flyer wrote:Do you mean, you changed the URL
from: http://www.stickypassword.com/forum
to: http://www.stickypassword.com/forum/ucp.php?mode=login
and then the auto-login executed as expected?

Yes, I changed my Firefox bookmark to:
http://www.stickypassword.com/forum/ucp.php?mode=login
Keep in mind I am "launching" the forum from Firefox bookmarks, not Sticky. Sticky is too laggy, particularly if you must search (8-10 seconds for a simple search, and never use the backspace key in the search field).
chaosxian
Experienced user
 
Posts: 105
Joined: Wed Apr 03, 2013 6:23 pm

Re: Sticky Forum (and others) Autologin

Postby John Flyer » Tue May 14, 2013 1:34 pm

To me it does not matter what URL I am using, neither is there any difference between Sticky's <Launch> or the browser's bookmark (Chrome, Firefox or IE8). The fields are always populated and the form is submitted if I have checked 'Automatic Log-in'.

Chaosxian wrote:Sticky is too laggy, particularly if you must search (8-10 seconds for a simple search, and never use the backspace key in the search field).

Really? I am afraid there is something wrong with your installation. Do you have a huge number of accounts? I have less than 100 and the search feature is excellent. What about back-spacing? On my computer BS works as expected.

Env: Windows7 x64, SP 6.0.9.439
John Flyer
Experienced user
 
Posts: 125
Joined: Fri Jan 18, 2013 11:33 am

Re: Sticky Forum (and others) Autologin

Postby chaosxian » Tue May 14, 2013 8:05 pm

John Flyer wrote:
Chaosxian wrote:Sticky is too laggy, particularly if you must search (8-10 seconds for a simple search, and never use the backspace key in the search field).
Really? I am afraid there is something wrong with your installation. Do you have a huge number of accounts? I have less than 100 and the search feature is excellent. What about back-spacing? On my computer BS works as expected.

Env: Windows7 x64, SP 6.0.9.439
I have 484 records. It takes about 5 seconds to open Sticky from the tray with one left click. When I enter "cky" in the search bar, the "c" appears instantly in the search bar, however it takes about 4 seconds for the "k" to appear, another 3-4 seconds for the "y" to appear, and then the results display in less than one second. If I mis-type while I enter the search term, it seems to slow again when I backspace to remove the unwanted character.

It's as though Sticky is searching for the "c", then having found that subset of records it searches for "ck", and then finally "cky". If I type in a longer term, for example "amazon", the latter letters take less and less time to appear(presumably fewer records are scanned as each successive letter markedly reduced the possible results).

FWIW, this is really OT for "autologin", but I wanted to respond to your remark. And yes, I've reinstalled Sticky, and exported/imported my database. Still I love Sticky, having tried others that all fall short of my needs in some way. [Win764]
chaosxian
Experienced user
 
Posts: 105
Joined: Wed Apr 03, 2013 6:23 pm

Re: Sticky Forum (and others) Autologin

Postby Evzen » Tue May 14, 2013 8:41 pm

Looks like 100 accounts is about the magic number - until recently I had less than 100 accounts and had no problem with slow search... now I have just over 100 accounts and I start observing slowdowns.
Well, enough of the OT... ;-)
Evzen
Experienced user
 
Posts: 163
Joined: Tue Jul 03, 2012 1:33 am


Return to Sticky Password PRO 6

Who is online

Users browsing this forum: No registered users and 0 guests